admin管理员组

文章数量:1123882

Not sure if it's related to Zscaler, but I started to receive this warning about the Docker.app the same day that I installed and restarted Zscaler.

Full warning: "Docker.app" will damage your computer. You should move it to the Bin

I am using MacOS Intel.

Not sure if it's related to Zscaler, but I started to receive this warning about the Docker.app the same day that I installed and restarted Zscaler.

Full warning: "Docker.app" will damage your computer. You should move it to the Bin

I am using MacOS Intel.

Share Improve this question edited yesterday W-B 1,0286 silver badges18 bronze badges asked yesterday Stefano BorzìStefano Borzì 1,4242 gold badges21 silver badges39 bronze badges 3
  • 6 this is a disastrous global issue for software engineering. the question warrants being reopened. reddit.com/r/docker/comments/1hvy7hx/… – Kirby Commented yesterday
  • 1 Agreed. This seems to be affecting a lot of developers worldwide. Valid question IMO. – Jules Colle Commented yesterday
  • Can you please edit the question to include the code you've written? How would a programmer run into this, as opposed to a data scientist or a general user who's just trying to use software packaged in a Docker image? – David Maze Commented 59 mins ago
Add a comment  | 

2 Answers 2

Reset to default 6

There is an official response from Docker regarding attempts to resolve this issue, as well as suggested workarounds. The following is copied from the GitHub PR: https://github.com/docker/for-mac/issues/7520.

Note: While I cannot confirm if the creator of the PR represents Docker, the official Docker account references this PR on LinkedIn.

If you face this issue, try the following procedure:

  1. Quit Docker Desktop and ensure no remaining Docker processes are running using the Activity Monitor.

  2. Run the following commands:

    #!/bin/bash
    
    # Stop the docker services
    echo "Stopping Docker..."
    sudo pkill '[dD]ocker'
    
    # Stop the vmnetd service
    echo "Stopping com.docker.vmnetd service..."
    sudo launchctl bootout system /Library/LaunchDaemons/com.docker.vmnetd.plist
    
    # Stop the socket service
    echo "Stopping com.docker.socket service..."
    sudo launchctl bootout system /Library/LaunchDaemons/com.docker.socket.plist
    
    # Remove vmnetd binary
    echo "Removing com.docker.vmnetd binary..."
    sudo rm -f /Library/PrivilegedHelperTools/com.docker.vmnetd
    
    # Remove socket binary
    echo "Removing com.docker.socket binary..."
    sudo rm -f /Library/PrivilegedHelperTools/com.docker.socket
    
    # Install new binaries
    echo "Installing new binaries..."
    sudo cp /Applications/Docker.app/Contents/Library/LaunchServices/com.docker.vmnetd /Library/PrivilegedHelperTools/
    sudo cp /Applications/Docker.app/Contents/MacOS/com.docker.socket /Library/PrivilegedHelperTools/
    
  3. Restart Docker Desktop.

If that still doesn't work, download one of the currently supported releases from the Release Notes and reapply step 2.

I solved extracting the Docker.app from the Docker.dmg after mounting it and copying it into /Applications/ using

mv ~/Downloads/Docker.app /Applications/

Another potential solution can be running the following command and dragging the Docker.app in /Applications/ again:

softwareupdate --install-rosetta

source

本文标签: How to resolve the quot39Dockerapp39 will damage your computerquot warning on MacOSStack Overflow